Disney Castle Lighting

Rob, now that I have installed your amazing kit, I want to thank you for creating this awesome enhancement to the Castle!!!

Here are shots of it in full glory!

Hugh

73replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Michael Organiscak what do you mean by  "Disney castle lighting take 75"? I think my castle lights have been jinxed. As soon as you got yours to work, my lights would not turn on all of the sudden. And it's all having the same symptoms as yours.

     

    I've done the troubleshoot.

    1. 24" cable connected from power (both usb and battery) to main control module - no lights on the main control module. Assume the wire is faulty.

     

    2. Tried connecting a shorter cable from power to main control module. Green lights lit up but still no lights from any parts of the castle. Sometimes I would get a flicker of light when connected.

    3. Isolated all 4 cables from the main control module and connected it separately to the power source and all lights works.

    4. The cable connecting from the power source to the main control module is definitely connected to the correct connector as the lights were working before this.

     

    Rob Klingberg do I need another 24" black cable for it to work? Or it doesn't matter?

    Like
  • Rob Klingberg

    Could this probably be a faulty infrared receiver or remote? I've changed the batteries on the remote and it still did not work. What is the default setting (on/off) of the main control module once connected without pressing anything on the remote? Any way to troubleshoot for this? Thanks.

    Like
  • Daryl Tan You can use any length cable-- there are spare cables provided with the kit.

    Like
  • Daryl Tan I don't know what could have happened to your set.  How did you have the settings before it stopped working?  The control board remembers its settings, so if lights were on before, they will be on again.  If all were off, they will be off.  If you'd like to send your remote, main control board, and infrared receiver back to us, we will troubleshoot, fix, and return.

    Like
  • Rob Klingberg the setting was always on fireworks. And then one day it stopped working. I realized the 24" cable connectors came off (cable to connector, not connector male to female). I cut off an extra wire with an attached connector and joined them with the 24" cable. Only white lights came on thereafter. Come 2 weeks, it just couldn't be turned on and I decided to troubleshoot and try to identify the issue. My best guess would be the remote as I realized there no infrared lights from the remote when I press it or even when I change battery. Does the brand and quality of battery matters? Might go and get another type of battery to try out. Will get in touch with you separately on what I should do. Probably cheaper for me to get a new remote rather than having to send them back. Thanks :)

    Like
  • Daryl Tan Hmm interesting.   Why did the cable connector come off?  Let me know what you find out with the new remote battery.  Brand shouldn't matter, just make sure the size/type is the same.

    Like
  • Rob Klingberg my remote still isn’t working. I changed battery out and everything. What’s next? 

     

    Let me reiterate that the lights work now, which I’m incredibly thankful for the help with. I just need the remote working now.  

     

    Ill buy a new one or another IR cable

    Like
  • Michael Organiscak Would you be able to send your remote back to us?  I'll have a look and either get it working again or send you a new one.

    Like
  • Rob Klingberg yeah I can send in tomorrow. 

    Like
  • Rob Klingberg well well  well. I figured out the remote issue and not sure how to correct it. My castle is currently on top of my movie case, and I noticed the lights going in and out randomly. Like the torches or the white lights and it was blowing my mind. Then this morning I was watching baby sign language with my son, and I adjusted the volume on the sound bar. I realized a few minutes later that the white lights went back on. 

    Then I grabbed the remote again and realized the volume button on my sound bar remote control the lights. Lol. Is there any way to fix that interference? I’m pretty sure the only ability I have is to turn on and off. I can no longer adjust flicker sensitivity (I think). 

    Like
  • Rob Klingberg Daryl Tan

    wrong remote!

    Like
  • Michael Organiscak Wow, that's some good troubleshooting!  But not the scenario you want.  The IR codes are hard-coded into the remote itself, so there is nothing we can do to change them.  I do have a new prototype control board however that uses radio frequency remotes instead of IR-- these have much longer range, don't need line-of-sight, and the remotes are coded to work only with their receiver.  If you'd be willing to be a guinea pig for this new (still unreleased) control board, I could send you one along with an RF remote if you return your TRUNK05 control board, IR remote control, and IR receiver.

    Like
  • Rob Klingberg yes, please!

    Like
  • Rob Klingberg I will be taking apart the castle tomorrow to remove the pieces i need to send in.  Thanks again for your help and generosity.  I've been enjoying my lights (albeit with less control than i would have if the remote worked).  I've taken some awesome videos that i've finally been able to share with family and friends.  I can't wait to see how great it will be with the RF remote.

    Once we get this remote thing figured out we move on to the process of drilling through my turn table (if i even can) to be able to install a slip ring setup

     

    Daryl Tan would you mind giving me the dimensions of your acrylic box? it really looks amazing and is the next step to finishing my castle.

     

    So, full disclosure, i haven't been paying much attention to lego since i was a boy.  I only plan to have this castle and the hogwarts castle in my lego collection until my son gets into it (if he does).  I did some research about those awesome disney characters i've seen in others' pictures, and found those come randomly in packs.

    If anyone has duplicates they're willing to part with, i'm looking for some specific characters.  Hit me up!

    Like
  • Ok, so haven't been on for a while here but was among the early adopters for this. Last weekend I was rebuilding the fireworks fiber bases in tan and white to better match the castle when I accidentally pulled 2 wires off of the first base first Pico light. Now, the entire string is out.  What's the easiest way to fix these?  Solder?, Solder paste?  how do you even strip a wire so thin?

    Thanks,

    Rick

    Like
  • Daryl Tan 

     I have to say your video is exactly what I’m hoping to accomplish! #goals. I’m hoping to do fireworks sound with the sound kit and play music over to get the full feel. Is this just on cycle or have you programmed the way it appears? Any tips now that you’ve done this?  

    Thank you.

    Like
  • Rick Prescott Hi Rick, sorry to hear about this! If you want to mail them back to us, we can fix the lights. Send us a note to support@brickstuff.com if you're interested.

    Like
  • Hi Rob, new issue.  Lights are completely out.   If I wiggle the connector from the USB cord to the main board I get a brief flicker of light.  Does this sound like a short somewhere or an issue with the main board or USB connector?

    Thanks,

    Rick

    Like
  • Rick Prescott Is the green light "on" on the main control board?  If so, it could just be that your master power switch is off.  Press the main power button on the remote (top center), then try the A, B, and C buttons again.

    Like
  • Hi Rob, It appears to be something with the Branch04 board.  I connnected the USB cord to the upper tower directly and it lit the lights.  I managed to wiggle it enought to find the perfect position for it on the Branch04 board and it lit up the castle so I ordered a new set of Branch04 boards.

    thanks

    Like
  • Rick Prescott Ah, ok well that's a simple solution!  Let me know if it works or if we still have troubleshooting work to do.

    Like
  • I think the light set in my castle is the first version with all the extras (I have the fireworks, remote, and something else which I can't recall). What I want to do is put the lights on a timer so that the castle is lit up during certain times of the day. I'm doing this by putting a smart plug which cuts power to the castle. When I tried it, sometimes nothing lights up. The next day all the lights are on. Other days some different combination of lights are on. I'm assuming the light kit forgets the last state before it was powered off and thus the random behavior. Any suggestions?

    Like
  • Manuel Díaz Yes, that is correct-- the state of the lighting is saved inside the controller.  If the lights are not coming back on in their previous setting, this is likely caused by the power on/off signal not being "clean".  What this means is that there can be little spikes when the power comes on and also when it goes off-- these can cause glitches in the controller (not harmful, but causing it to "forget" its last settings).  Do you have another smart plug you could try?  Or maybe try it first with a regular corded on/off switch.  See if that makes a difference.  We are also working on our own smart WiFi controller that will work with Amazon Alexa and Google, so if that might work for you also, that controller should be out later this year.

    Like
Like Follow
  • 4 mths agoLast active
  • 73Replies
  • 1221Views
  • 12 Following