Disney Castle stuck in Fireworks mode, when I don't even have the fireworks expansion.

Hi, I've had this kit for a couple years with no problem at all. I absolutely love it to the point it's basically the centerpiece of my living room, but a few weeks ago when I turned the lights on as I do every morning I noticed it was doing the effects I saw for the Fireworks expansion, and I don't even have that expansion.

Since then I have unplugged the power and even individual cables and plugged them back in multiple times and nothing seems to get it back to the solid colors I use just like on the first level you see in the video. It's also worth mentioning I have the split level exterior only kit.

Can someone please provide some help on how I can fix this? Thank you for your time.

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Eric, thank you for your post.  This isn't the fireworks expansion mode, just the normal fireworks mode.  As outlined in the instructions, you can switch between the color-changing mode and fireworks mode by pressing the small white button on the lighting effect controller that's connected to the top-level color-changing spotlights.  Sometimes the mode can switch back to fireworks mode if there is a power surge in the supply.  If you can push the white button for the effect controller connected to the top-level spots, this should fix the issue.

    If not, please let us know.  Thank you.

    Like
  • Rob Klingberg Wow! Thank you so much! I totally forgot about that option, and did not realize that was a button until you pointed it out, so thank you. I was able to fix it, and it looks great once again. Have a great day!

    Like
  • Eric Pearson Glad you got it working again!

    Like
Like Follow
  • 2 wk agoLast active
  • 3Replies
  • 9Views
  • 2 Following