Disney Castle Lighting Issue

Just finished wiring the complete kits for the castle, but the circuit containing front upper spotlights, tower lights, centre strip light, front lower spotlights, clock light does not light up. The circuit diagram seems to show the connection to the A4 Adaptor Board of this circuit comes from the A4 board of the bottom section, but the middle section cable is connected to it already? All other lights work ok but no power gets to the circuit, if I plug it into any other A4 board spare connection it turns all the other working lights off.

Any help is appreciated.

13replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Andrew - I gotta grab my build instructions, but off the cuff it sounds like both something is plugged in oddball, and ultimately, creating a short-circuit (the telltale of the working lights being switched off).

    That said, I recall there was some head-scratching when I put all mine together, though ultimately it did come together with some re-work (and in my case, closer adherence to the plans).

    In terms of what DOES work when you power it on, is it specific to any one area, "kit" (interior, exterior, fireworks), or...?  And probably not applicable, but I am visual, so if there's photos of connections, those never hurt...

    Reply Like
  • Hi Andrew Warsop , from what you described, it definitely sounds like a pinched wire or other short circuit.  We put together a troubleshooting guide that may help-- please see the PDF attached to this post and let us know if it helps.  We'll get you up and running!

    Reply Like
  • Thanks for looking into this for me, but before I check for pinched wire etc., could you please just confirm where this circuit takes it's power from, ( which port on which A4 board) as it looks like the interior lights use the position that the spotlight circuit needs to use.

    Reply Like
  • So, I'm halfway useless - I can't find my install instructions to be certain WHICH BRANCH4 (A4)  you're looking at Andrew Warsop ...

    Happy to tear down my castle a bit and get a look and a photo or two - for the A4 you're looking at, whereabouts is it located?  Or are you looking to verify the plug-in arrangement of several?

    Reply Like
  • Andrew Warsop Hi Andrew, looking at the diagrams, I can see where the confusion is coming from.  The wiring diagrams in the interior lighting kit show the upper level being connected to an A4 board which is directly connected to the main controller.  The wiring diagrams in the exterior lighting kit show two A4 boards.  See the photo below (interior diagram is on the right, exterior diagram is on the left):

     The diagram on the left is correct.  The upper level should be connected to the one open connector on the first A4 board coming off the main controller (you can see the open plug inside the blue circle in the left diagram).  Note that all plugs on our adapter boards are electrically connected-- it doesn't make a difference which plug you connect lights to.  All plugs are connected, so attaching the cable coming down from the upper level to any open plug is ok.

    I hope this helps clarify.  This is a change we will make in our instructions moving forward.

    Reply Like
  • Just an update on my wiring situation. Unplugged each connector in turn, and identified there was indeed a trapped cable from the clock that was cutting the power to the circuit. I reconnected everything and tested using the remote, all lighting circuits working ok individually. But when I set the colour changing spotlights +the flickering internal lights+the static white exterior spotlights and tower light on together the external set stayed on only about 15 seconds and switched off completely and will not light up anymore. Before I strip it down again is there a reason you can think of for this to happen.

    Reply Like
  • Andrew Warsop Just so I understand, when you have all lights connected to the IR receiver/master controller, and when you turn one channel of lights on at a time, they all work, but when you turn them all on at the same time, power goes off after 15 seconds?  This doesn't sound like a short circuit-- if you had a short circuit, the lights wouldn't work even for 15 seconds.  It sounds like a low-power situation, where the system is receiving enough power to run 1 channel of lights at a time, but when you turn them all on, there isn't enough power to keep things going.  I see you ordered our USB cable with your order-- what are you using to power the USB cable?  The adapter you're using should be able to put out at least 1A of power.  We've seen situations in the past where people use the USB port on their computer (which can only provide 500mA), or are using a generic mains adapter that can't put out enough power.  Is there any way you can test with multiple adapters to see if one does a better job?  We recommend using a genuine Apple brand charger if you have one-- these have very good power output levels.  Please let us know what you find out, and thanks for taking the time to do the hard work of troubleshooting.

    Reply Like
  • Yes I am using my Apple adaptor to power the USB. When I tried each channel they all worked okay, and the colour changing spotlights and flickering lights still are okay and run fine together. But the other channel does not light up at all even with the other two channels switched off, this channel has not lit up since the initial "all sequence  on trial run"

    Reply Like
  • Andrew Warsop Thanks again for the details.  So it's the channel with the interior lights that does not work-- is that correct?  Can you try connecting the wire for those lights directly to power to see if they work even for a few seconds?  Can you also try connecting just the interior tower lights to power (not the interior base lights)?  Need to see if there is a problem with the controller itself or if there is still a pinched wire somewhere on the interior circuit.  Thank you!

    Reply Like
  • Lights that work.

    Colour changing spotlights base and mid section.

    Fireworks

    Flickering lanterns

    Flickering torches

    Chandelier

    Candlestick

    Fireplace

    All other lights do not work.

    I will try plugging problem circuit into power at my next available time. Thanks

    Reply Like
  • Andrew Warsop Thanks for the info.  So it sounds like the one channel that's not working is the one with the interior lights (non-flickering ones) and the exterior white spotlights.  If you could try plugging segments of that circuit into power directly to see if the problem can be isolated to one section (top castle section, middle castle section, lower castle section), that will help.  Also still trying to understand how the lights would have come on for 15 seconds but then turned off-- typically that's not related to a short-circuit, but if they now don't come back on at all, it may be.

    Reply Like
  • Some good news, everything is working fine now. Did as you suggested and tried each circuit connected directly to power and the exterior section just flashed briefly and then went out each time power was applied. Even though none of the wires where trapped as such, one must have been slightly to tight. Why it worked when I initially tested it is a mystery, but all is okay now. Thanks for your help, castle looks amazing.

    Reply Like
  • Andrew Warsop so glad to hear it.  Thank you again for your patience in trying all of the resolution steps!

    Reply Like
reply to topic
Like Follow
  • 8 mths agoLast active
  • 13Replies
  • 391Views
  • 3 Following