Damaged Trunk08 board in Lego haunted House kit

Hi Rob,

ORDER No 502159287

I have just got round to connecting the Trunk08 board and noticed that the PIXEL plug has separated from the board. I noticed it loose in the bag when the kit arrived but assumed it was an adaptor or connector. It was only when I came to connect the three wire cable to it that I realised what it was.

Could you send a replacement ASAP please.

Kind Regards

Alan

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Sure thing Alan!  We'll get a replacement on its way.

    Like
  • Rob Klingberg 

    Thanks Rob

    Arrived today everything working great

    Just one comment, would have preferred a quieter soft touch remote like the one I got with the Cinderella Castle light kit so you can’t hear the clicks when making a video

    Other than that minor issue (and I’m sure there’s a reason why) I’m really pleased with the kit

    Regards

    Alan

    Like
  • Alan Overton Hi Alan, thanks for the follow up-- I'm glad the replacement arrived and that all is now working well.  You're not the first to question the "click" sound on the new remotes-- you can imagine my wife's comments when I'm testing kits at home!  Unfortunately, since we don't buy parts in quantities of 10,000's, we're not able to specify the type of switches used in the remotes.  We'll keep looking for better options and will keep the noise factor in mind.

    Thank you again.

    Like
Like Follow
  • 5 mths agoLast active
  • 3Replies
  • 10Views
  • 2 Following