Disney Castle remote not working

Can someone help me?  Nothing responds to my Remote: no sound, the color changing lights do not change color, fireworks never change, etc.  I love the lights, but they would be better if everything worked.

Thanks for the help.

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Thanks for the message-- sorry to hear about the trouble!  You have the Castle with the white RF remote and four buttons, correct?  A few questions to help us troubleshoot:

    1.  On the remote receiver (attached to the castle and connected to the main TRUNK08 effects controller), is the little light on when power to the castle is on?  There is a separate small light on the remote receiver itself (either red or blue) that should be on.

    2.  When you press the buttons on the remote, does the little light on the remote turn on?

    3.  If the remote light works, when you press any remote button, does the light on the remote receiver change?  It should flash or turn on/off in response to any button press on the remote.

    If the answer to #1 is "no," then you'll need to check the power connections for the remote receiver itself.

    If the answer to #2 is "no," then check the battery inside the remote transmitter.

    If the answer to #3 is "no," then you can re-associate your remote with the receive by following these steps:

    1.  On the receiver board, there is a small white button.  Press and hold this when power is on for 10 seconds.  The little light on the receiver should turn on and then turn off after 10 seconds.  It is important to keep holding the button on the receiver until the light turns off.

    2.  Release the button, wait 2-3 seconds, then press and hold it again for 2-3 seconds.  Release.

    3.  Press any button on your remote transmitter.  The light on the receiver should flash in response to the button presses, indicating that the remote is re-associated with the receiver.

     

    Hopefully the steps above should get you back on track.  Please let us know what happens.

    Like
  • @Rob Klingberg     \

     I attempted remedy #3 (because the light on the receiver does not change when the Remote is pressed),  however on TRUNK08, where there is a button pictured in the instructions, I have no button...just four tiny solder marks.

    Like
  • Ned Nichols Sorry, the white button I was referring to is on the small remote receive board itself, not the TRUNK08.  You can see it in the upper right corner of the receiver in the photo below:

    Let me know if this helps, thanks!

    Like
  • No matter how long I hold the white button down, the light on the receiver does not go off.

    Like
  • Ned Nichols Hmm, ok.  So the light on the receiver is on, and it stays on even after you hold down the white button for 10+ seconds?  How about if you hold it for 20 seconds?

    Has the remote ever worked?  Maybe we need to send you a replacement.

    Like
  • Rob Klingberg 

    The remote has never worked.  The indicator light comes on whenever a button is pressed, but the lights on the castle have never responded.

    The light on the receiver stays on no matter how long I hold the white button down.

    Like
  • Ned Nichols 

    Any other suggestions?   Thanks.

    Like
  • Ned Nichols We can send you a replacement remote + module. Please send us an e-mail to support(at)brickstuff.com with your current mailing address. Thank you!

    Like
Like Follow
  • 3 wk agoLast active
  • 8Replies
  • 8Views
  • 2 Following