4-LED Pico Rotating Beacon

Apologies if this info is somewhere else. 

I am trying to use a 4-LED Pico Rotating Beacon connected to a pFX brick via a picoLABduo connector (both from Fx Bricks).  Using a simple on/off startup action.  One LED lights but no rotating action. Any suggestions appreciated. Apologies again if I have got the wrong idea.

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Andrew, and thank you for your message-- and most importantly, sorry for the delay in responding!

    OK, so with  your beacon, we've never tried it in the specific configuration you're using.  Have you tried connecting it directly to a power source (i.e., not through the PFx Brick)?  The reason I ask is because I believe the PFx Brick uses Pulse Width Modulation (PWM) for its outputs, which is how most digital systems create effects like dimming.  With PWM, the power to an output or light is turned on and off very fast-- so fast that the human eye can't see it.  While our eyes see PWM-controlled outputs as bright or dim, sensitive electronic equipment like the effect chip in the micro rotating beacon doesn't like when its power goes on and off (even very quickly).  Even though you may have set 100% brightness for the PFx output the beacon is connected to, the PFx Brick may still be pulsing the output.  If so, this can cause the behavior you're seeing on the beacon-- basically it's trying to start up but every time it does, the power goes off (even for a milisecond), then it tries to start over, etc.  but because the power it's receiving is never (digitally) constant, it never gets the chance to start up and do its rotation thing.

    Since I haven't tried your specific configuration, and of course since I don't know the inner workings of the PFx Brick, I can't say for sure this is what's happening, but one sure way to tell is to connect the beacon to a power source directly.  If it works there, then the issue is with the PFx Brick and how it's managing the power being sent to your beacon.

    Hopefully this helps-- let me know if you are able to validate/test any of these behaviors, and what the results are.

    Thank you.

    Like 1
  • Rob Klingberg  that’s a great answer. I will try with a regular power supply. Many thanks.

    Like
  • Andrew Statham Absolutely, please keep us posted.

    Like
  • Connecting to a power source directly works fine. Also, on the PFx Brick, it seems that the default brightness setting for the lighting outputs is less than "full". Setting the brightness to full starts the beacon rotating. Not clear from the attached specification if lighting outputs use PWM.

    Like
  • Andrew Statham Thanks for the additional information.  I'm glad to hear the beacon is working.  If the beacon works with the PFx Brick set to full brightness, then you should be ok using it long-term.  Just make sure that whatever output you connect the beacon to is always either on (100%) or off (0%).

    Like
  • Many thanks for your assistance. Much appreciated.

    Like 1
Like Follow
  • 2 days agoLast active
  • 6Replies
  • 10Views
  • 2 Following